# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^\d+ ?[gm]b | \d+ ?[gm]b(?= |$))//gm;t' <<< "coolblue 100gb
connector 500 mb for thing
5gb for user
load 800 mb
1000 add-on
20 gb "