use strict;
my $str = 'coolblue 100gb
connector 500 mb for thing
5gb for user
load 800 mb
1000 add-on
20 gb ';
my $regex = qr/(?:^\d+ ?[gm]b | \d+ ?[gm]b(?= |$))/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";