re = /(?:^\d+ ?[gm]b | \d+ ?[gm]b(?= |$))/m
str = 'coolblue 100gb
connector 500 mb for thing
5gb for user
load 800 mb
1000 add-on
20 gb '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result