#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^\d+ ?[gm]b | \d+ ?[gm]b(?= |$))"
Local $sString = "coolblue 100gb" & @CRLF & _
"connector 500 mb for thing" & @CRLF & _
"5gb for user" & @CRLF & _
"load 800 mb" & @CRLF & _
"1000 add-on" & @CRLF & _
"20 gb "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)