const regex = new RegExp('(?:^\\d+ ?[gm]b | \\d+ ?[gm]b(?= |$))', 'gm')
const str = `coolblue 100gb
connector 500 mb for thing
5gb for user
load 800 mb
1000 add-on
20 gb `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);