$re = '/(?:^\d+ ?[gm]b | \d+ ?[gm]b(?= |$))/m';
$str = 'coolblue 100gb
connector 500 mb for thing
5gb for user
load 800 mb
1000 add-on
20 gb ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;