import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^\\d+ ?[gm]b | \\d+ ?[gm]b(?= |$))";
final String string = "coolblue 100gb\n"
+ "connector 500 mb for thing\n"
+ "5gb for user\n"
+ "load 800 mb\n"
+ "1000 add-on\n"
+ "20 gb ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}