using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^\d+ ?[gm]b | \d+ ?[gm]b(?= |$))";
string substitution = @"";
string input = @"coolblue 100gb
connector 500 mb for thing
5gb for user
load 800 mb
1000 add-on
20 gb ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}