#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)vector_name=(\w+)"
Local $sString = "options={}, params={vector_name=get_x, default_like_count=2, seeting_id=1200, system=0 back" & @CRLF & _
"literal options={}, params={setting_id=1200, seed_val=22, system=0, vector_name=get_Z foobar}" & @CRLF & _
"params={seed_rand=1200, seed_val=22, system=0, vector_name=corodinate2, tt=lly}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")