const regex = new RegExp('vector_name=(\\w+)', 'gm')
const str = `options={}, params={vector_name=get_x, default_like_count=2, seeting_id=1200, system=0 back
literal options={}, params={setting_id=1200, seed_val=22, system=0, vector_name=get_Z foobar}
params={seed_rand=1200, seed_val=22, system=0, vector_name=corodinate2, tt=lly}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}