re = /vector_name=(\w+)/m
str = 'options={}, params={vector_name=get_x, default_like_count=2, seeting_id=1200, system=0 back
literal options={}, params={setting_id=1200, seed_val=22, system=0, vector_name=get_Z foobar}
params={seed_rand=1200, seed_val=22, system=0, vector_name=corodinate2, tt=lly}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end