import re
regex = re.compile(r"vector_name=(\w+)", flags=re.MULTILINE)
test_str = ("options={}, params={vector_name=get_x, default_like_count=2, seeting_id=1200, system=0 back\n"
"literal options={}, params={setting_id=1200, seed_val=22, system=0, vector_name=get_Z foobar}\n"
"params={seed_rand=1200, seed_val=22, system=0, vector_name=corodinate2, tt=lly}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")