import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "vector_name=(\\w+)";
final String string = "options={}, params={vector_name=get_x, default_like_count=2, seeting_id=1200, system=0 back\n"
+ "literal options={}, params={setting_id=1200, seed_val=22, system=0, vector_name=get_Z foobar}\n"
+ "params={seed_rand=1200, seed_val=22, system=0, vector_name=corodinate2, tt=lly}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}