# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-(?:[AR](?:-(?:OK|NG))?|W|C)$//gm;t' <<< "Word1-A-OK
Word2-Sample-R-OK
Word3-A
Word1-R
Word2-Sample-A-NG
Word3-R-NG
Word1-W
Word2-Sample-C"