#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)-(?:[AR](?:-(?:OK|NG))?|W|C)$"
Local $sString = "Word1-A-OK" & @CRLF & _
"Word2-Sample-R-OK" & @CRLF & _
"Word3-A" & @CRLF & _
"Word1-R" & @CRLF & _
"Word2-Sample-A-NG" & @CRLF & _
"Word3-R-NG" & @CRLF & _
"Word1-W" & @CRLF & _
"Word2-Sample-C"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)