// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)-(?:[AR](?:-(?:OK|NG))?|W|C)$").unwrap();
let string = "Word1-A-OK
Word2-Sample-R-OK
Word3-A
Word1-R
Word2-Sample-A-NG
Word3-R-NG
Word1-W
Word2-Sample-C";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}