package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-(?:[AR](?:-(?:OK|NG))?|W|C)$`)
var str = `Word1-A-OK
Word2-Sample-R-OK
Word3-A
Word1-R
Word2-Sample-A-NG
Word3-R-NG
Word1-W
Word2-Sample-C`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}