use strict;
my $str = 'Word1-A-OK
Word2-Sample-R-OK
Word3-A
Word1-R
Word2-Sample-A-NG
Word3-R-NG
Word1-W
Word2-Sample-C';
my $regex = qr/-(?:[AR](?:-(?:OK|NG))?|W|C)$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";