re = /-(?:[AR](?:-(?:OK|NG))?|W|C)$/m
str = 'Word1-A-OK
Word2-Sample-R-OK
Word3-A
Word1-R
Word2-Sample-A-NG
Word3-R-NG
Word1-W
Word2-Sample-C'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result