import re
regex = re.compile(r"-(?:[AR](?:-(?:OK|NG))?|W|C)$", flags=re.MULTILINE)
test_str = ("Word1-A-OK\n"
"Word2-Sample-R-OK\n"
"Word3-A\n"
"Word1-R\n"
"Word2-Sample-A-NG\n"
"Word3-R-NG\n"
"Word1-W\n"
"Word2-Sample-C")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)