import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-(?:[AR](?:-(?:OK|NG))?|W|C)$";
final String string = "Word1-A-OK\n"
+ "Word2-Sample-R-OK\n"
+ "Word3-A\n"
+ "Word1-R\n"
+ "Word2-Sample-A-NG\n"
+ "Word3-R-NG\n"
+ "Word1-W\n"
+ "Word2-Sample-C";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}