# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@default\.(.*?)@[^\r\n]+(?=[\s\S]*@\1@)/byomakesh.x.parida@aib.ie/g;t' <<< "@default.RR.TT@=393993
@default.h.i.j@=234
@asdfasd.fasdfs.asdfa@=23423
@default.a.b.c@=QQQ
@h.i.j@=aaaa
@a.b.c@=x
@d.e.f@=y"