$re = '/@default\.(.*?)@[^\r\n]+(?=[\s\S]*@\1@)/';
$str = '@default.RR.TT@=393993
@default.h.i.j@=234
@asdfasd.fasdfs.asdfa@=23423
@default.a.b.c@=QQQ
@h.i.j@=aaaa
@a.b.c@=x
@d.e.f@=y';
$subst = "byomakesh.x.parida@aib.ie";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;