use strict;
my $str = '@default.RR.TT@=393993
@default.h.i.j@=234
@asdfasd.fasdfs.asdfa@=23423
@default.a.b.c@=QQQ
@h.i.j@=aaaa
@a.b.c@=x
@d.e.f@=y';
my $regex = qr/@default\.(.*?)@[^\r\n]+(?=[\s\S]*@\1@)/p;
my $subst = 'byomakesh.x.parida@aib.ie';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";