import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@default\\.(.*?)@[^\\r\\n]+(?=[\\s\\S]*@\\1@)";
final String string = "@default.RR.TT@=393993\n"
+ "@default.h.i.j@=234\n"
+ "@asdfasd.fasdfs.asdfa@=23423\n"
+ "@default.a.b.c@=QQQ\n"
+ "@h.i.j@=aaaa\n"
+ "@a.b.c@=x\n"
+ "@d.e.f@=y";
final String subst = "byomakesh.x.parida@aib.ie";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}