using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@default\.(.*?)@[^\r\n]+(?=[\s\S]*@\1@)";
string substitution = @"byomakesh.x.parida@aib.ie";
string input = @"@default.RR.TT@=393993
@default.h.i.j@=234
@asdfasd.fasdfs.asdfa@=23423
@default.a.b.c@=QQQ
@h.i.j@=aaaa
@a.b.c@=x
@d.e.f@=y";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}