# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"@default\.(.*?)@[^\r\n]+(?=[\s\S]*@\1@)"
test_str = ("@default.RR.TT@=393993\n"
"@default.h.i.j@=234\n"
"@asdfasd.fasdfs.asdfa@=23423\n"
"@default.a.b.c@=QQQ\n"
"@h.i.j@=aaaa\n"
"@a.b.c@=x\n"
"@d.e.f@=y")
subst = "byomakesh.x.parida@aib.ie"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.