import Foundation
let pattern = #"@default\.(.*?)@[^\r\n]+(?=[\s\S]*@\1@)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
@default.RR.TT@=393993
@default.h.i.j@=234
@asdfasd.fasdfs.asdfa@=23423
@default.a.b.c@=QQQ
@h.i.j@=aaaa
@a.b.c@=x
@d.e.f@=y
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"byomakesh.x.parida@aib.ie"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)