#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "@default\.(.*?)@[^\r\n]+(?=[\s\S]*@\1@)"
Local $sString = "@default.RR.TT@=393993" & @CRLF & _
"@default.h.i.j@=234" & @CRLF & _
"@asdfasd.fasdfs.asdfa@=23423" & @CRLF & _
"@default.a.b.c@=QQQ" & @CRLF & _
"@h.i.j@=aaaa" & @CRLF & _
"@a.b.c@=x" & @CRLF & _
"@d.e.f@=y"
Local $sSubst = "byomakesh.x.parida@aib.ie"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)