const regex = /@default\.(.*?)@[^\r\n]+(?=[\s\S]*@\1@)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@default\\.(.*?)@[^\\r\\n]+(?=[\\s\\S]*@\\1@)', 'g')
const str = `@default.RR.TT@=393993
@default.h.i.j@=234
@asdfasd.fasdfs.asdfa@=23423
@default.a.b.c@=QQQ
@h.i.j@=aaaa
@a.b.c@=x
@d.e.f@=y`;
const subst = `byomakesh.x.parida@aib.ie`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);