# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.+\\/topic\\/)([0-9]+)/$1$2-$2/gm;t' <<< "https://forum.thirtybees.com/topic/1064
https://forum.thirtybees.com/topic/1064/ksksskjsjks
https://forum.thirtybees.com/topic/1064/sdsdsdfs/
https://forum.thirtybees.com/topic/1064/3424-sdsdsdfs/
https://forum.thirtybees.com/topic/1064/1234/"