#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.+\/topic\/)([0-9]+)"
Local $sString = "https://forum.thirtybees.com/topic/1064" & @CRLF & _
"https://forum.thirtybees.com/topic/1064/ksksskjsjks" & @CRLF & _
"https://forum.thirtybees.com/topic/1064/sdsdsdfs/" & @CRLF & _
"https://forum.thirtybees.com/topic/1064/3424-sdsdsdfs/" & @CRLF & _
"https://forum.thirtybees.com/topic/1064/1234/"
Local $sSubst = "$1$2-$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)