$re = '/(.+\/topic\/)([0-9]+)/m';
$str = 'https://forum.thirtybees.com/topic/1064
https://forum.thirtybees.com/topic/1064/ksksskjsjks
https://forum.thirtybees.com/topic/1064/sdsdsdfs/
https://forum.thirtybees.com/topic/1064/3424-sdsdsdfs/
https://forum.thirtybees.com/topic/1064/1234/';
$subst = "$1$2-$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;