const regex = /(.+\/topic\/)([0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+\\\/topic\\\/)([0-9]+)', 'gm')
const str = `https://forum.thirtybees.com/topic/1064
https://forum.thirtybees.com/topic/1064/ksksskjsjks
https://forum.thirtybees.com/topic/1064/sdsdsdfs/
https://forum.thirtybees.com/topic/1064/3424-sdsdsdfs/
https://forum.thirtybees.com/topic/1064/1234/`;
const subst = `$1$2-$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);