import re
regex = re.compile(r"(.+\/topic\/)([0-9]+)", flags=re.MULTILINE)
test_str = ("https://forum.thirtybees.com/topic/1064\n"
"https://forum.thirtybees.com/topic/1064/ksksskjsjks\n"
"https://forum.thirtybees.com/topic/1064/sdsdsdfs/\n"
"https://forum.thirtybees.com/topic/1064/3424-sdsdsdfs/\n"
"https://forum.thirtybees.com/topic/1064/1234/")
subst = "$1$2-$2"
result = regex.sub(subst, test_str)
if result:
print(result)