package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+\/topic\/)([0-9]+)`)
var str = `https://forum.thirtybees.com/topic/1064
https://forum.thirtybees.com/topic/1064/ksksskjsjks
https://forum.thirtybees.com/topic/1064/sdsdsdfs/
https://forum.thirtybees.com/topic/1064/3424-sdsdsdfs/
https://forum.thirtybees.com/topic/1064/1234/`
var substitution = "$1$2-$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}