using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+\/topic\/)([0-9]+)";
string substitution = @"$1$2-$2";
string input = @"https://forum.thirtybees.com/topic/1064
https://forum.thirtybees.com/topic/1064/ksksskjsjks
https://forum.thirtybees.com/topic/1064/sdsdsdfs/
https://forum.thirtybees.com/topic/1064/3424-sdsdsdfs/
https://forum.thirtybees.com/topic/1064/1234/";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}