// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.+\/topic\/)([0-9]+)").unwrap();
let string = "https://forum.thirtybees.com/topic/1064
https://forum.thirtybees.com/topic/1064/ksksskjsjks
https://forum.thirtybees.com/topic/1064/sdsdsdfs/
https://forum.thirtybees.com/topic/1064/3424-sdsdsdfs/
https://forum.thirtybees.com/topic/1064/1234/";
let substitution = "$1$2-$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}