import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+\\/topic\\/)([0-9]+)";
final String string = "https://forum.thirtybees.com/topic/1064\n"
+ "https://forum.thirtybees.com/topic/1064/ksksskjsjks\n"
+ "https://forum.thirtybees.com/topic/1064/sdsdsdfs/\n"
+ "https://forum.thirtybees.com/topic/1064/3424-sdsdsdfs/\n"
+ "https://forum.thirtybees.com/topic/1064/1234/";
final String subst = "$1$2-$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}