# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?)\s*#quote {(.*?)\s*}(.*)(#quote {)(.*?)(}.*)$/\1\3\4\2\5\6/s;t' <<< "#any1 {
}
#quote {
padding-bottom: 20px;
font-size: 3.6vmin;
}
#any2 {
}
#quote {
text-align: center;
}
#any3 {
}"