$re = '/^(.*?)\s*#quote {(.*?)\s*}(.*)(#quote {)(.*?)(}.*)$/s';
$str = '#any1 {
}
#quote {
padding-bottom: 20px;
font-size: 3.6vmin;
}
#any2 {
}
#quote {
text-align: center;
}
#any3 {
}';
$subst = "\1\3\4\2\5\6";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;