import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)\\s*#quote \\{(.*?)\\s*\\}(.*)(#quote \\{)(.*?)(\\}.*)$";
final String string = "#any1 {\n"
+ "}\n\n"
+ "#quote {\n"
+ " padding-bottom: 20px;\n"
+ " font-size: 3.6vmin;\n"
+ "}\n\n"
+ "#any2 {\n"
+ "}\n\n"
+ "#quote {\n"
+ " text-align: center;\n"
+ "}\n\n"
+ "#any3 {\n"
+ "}";
final String subst = "\\1\\3\\4\\2\\5\\6";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}