re = /^(.*?)\s*#quote {(.*?)\s*}(.*)(#quote {)(.*?)(}.*)$/
str = '#any1 {
}
#quote {
padding-bottom: 20px;
font-size: 3.6vmin;
}
#any2 {
}
#quote {
text-align: center;
}
#any3 {
}'
subst = '\\1\\3\\4\\2\\5\\6'
result = str.sub(re, subst)
# Print the result of the substitution
puts result