package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)^(.*?)\s*#quote {(.*?)\s*}(.*)(#quote {)(.*?)(}.*)$`)
var str = []byte(`#any1 {
}
#quote {
padding-bottom: 20px;
font-size: 3.6vmin;
}
#any2 {
}
#quote {
text-align: center;
}
#any3 {
}`)
var substitution = []byte("\1\3\4\2\5\6")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}