// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)^(.*?)\s*#quote {(.*?)\s*}(.*)(#quote {)(.*?)(}.*)$").unwrap();
let string = "#any1 {
}
#quote {
padding-bottom: 20px;
font-size: 3.6vmin;
}
#any2 {
}
#quote {
text-align: center;
}
#any3 {
}";
let substitution = "\\1\\3\\4\\2\\5\\6";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}