using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)\s*#quote {(.*?)\s*}(.*)(#quote {)(.*?)(}.*)$";
string substitution = @"\1\3\4\2\5\6";
string input = @"#any1 {
}
#quote {
padding-bottom: 20px;
font-size: 3.6vmin;
}
#any2 {
}
#quote {
text-align: center;
}
#any3 {
}";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}