import Foundation
let pattern = ##"^(.*?)\s*#quote {(.*?)\s*}(.*)(#quote {)(.*?)(}.*)$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = ##"""
#any1 {
}
#quote {
padding-bottom: 20px;
font-size: 3.6vmin;
}
#any2 {
}
#quote {
text-align: center;
}
#any3 {
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\3\4\2\5\6"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}