#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{1,3})(\d{1,3})?(\d{1,4})?"
Local $sString = "0" & @CRLF & _
"01" & @CRLF & _
"012" & @CRLF & _
"0123" & @CRLF & _
"01234" & @CRLF & _
"012345" & @CRLF & _
"0123456" & @CRLF & _
"01234567" & @CRLF & _
"012345678" & @CRLF & _
"0123456789"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")