// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{1,3})(\d{1,3})?(\d{1,4})?").unwrap();
let string = "0
01
012
0123
01234
012345
0123456
01234567
012345678
0123456789";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}