re = /(\d{1,3})(\d{1,3})?(\d{1,4})?/
str = '0
01
012
0123
01234
012345
0123456
01234567
012345678
0123456789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end